No announcement yet.

Water heater not working

  • Filter
  • Time
  • Show
Clear All
new posts

  • Water heater not working

    I bought a 6 gal electric water heater at homedepot have used it for about 4 mon Its stoped working all of asudden the when I plug it in the start light wont turn on so my water is not heating up.

    Has this ever happend to anyone

    I dont know what caused it,whether its because of the constante movement of the truck, the only other thing that was giving me problem was that I used copper hoses to connect my tubing they kept breaking and leaking so I changed them to onece made of a different matirial that look like a regular hose. Im not sure if this is the problem but it worked fine for a couple of days and now its compleatly broken

    the manufactures are giving me such a hard time and want me to hire a plumer to fix it with their assistance over the phone in order to prove its defective and then maybe replace it under warenty(

    Im wondering if I should by a new one, has anyone used a 4 gal water heater? or is the 6 better any ideas on what could be wrong

  • #2
    Does it have an on/off switch that might have gotten swtiched or something? Just a guess.

    I did have an Arsin (spelling) 4 gal instant, I wouldn't go that small. I was always running out of hotwater. I now have a propane 6gal & love it, at times its too hot & I have to cool it down.

    The Soapy Puppy
    Last edited by Starshan; 03-09-10, 02:32 PM.


    • #3
      Its an aristol 6 gal it does hav an on off switch but it I've made sure that its on


      • #4
        You have most likely kicked the overheating breaker. this is not the on off switch, but a reset button behind the control panel. I tripped mine a few months back. If the water gets too hot or the heating element gets too hot it will trip the circuit. Its a simple push of a button. You might need to turn your thermostat down a click to keep it from happening again. It might have kicked the breaker if you ran it out of water unknowingly.


        • #5
          i got someone to take a look at It They told me it was the thermostat so I had to replace it. So far that did the trick it works now, I did run it when I was low on water so that might of been it