Announcement

Collapse
No announcement yet.

Question from pet owner

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Question from pet owner

    We are posting here. We get many in our email, getting a bit overloaded here...........thanks for helping us out.

    I have just bought ‘Treasure USB ‘ battery dog clippers. I presumed it was fully charged. Very pleased with the performance. However when I was all but finished clipping my wee cavalier spaniel, it ran down. So, I went to charge it, only to find the battery light didn’t come on, so I don’t know if it was charging. It has a blue coloured battery inside it, and a cord which I plug into socket. It does seem to have a small amount of charge, but I think that’s what was in it prior to charging. Can you help me please, to sort this problem out...or is it of no use now. When it was charging, it was plugged in approx 4 hours. I value your assistance. Many thanks.
    Coordinators post updates to the message for grooming events, members contests, PG.com Classified Ads, GroomerTALK Radio shows and PG.com Magazine online.

  • #2
    Read the instruction manual that came with it. If you still can't figure it out, call the manufacturer and tell them your problem.
    Old groomers never die, they just go at a slower clip.

    Groom on!!!

    Comment


    • #3
      I'm guessing these are the clippers being advertised all over facebook. All I can say is buyer beware. Pet clipper kits are usually one time use and done.

      If you're plugging them in and they are not charging I'm guessing you're going to be out of luck. Nobody here is going to be familiar with this clipper because it's simply not designed for professional use.

      Comment

      Working...
      X